Fehler bei der Sendungsverfolgung / Portal-Error bei Tracking-Links: „Momentan liegen uns keine Daten zu dieser Sendung vor“

Geändert am Mi, 15 Okt um 12:33 NACHMITTAGS


Beschreibung

Beim Klick auf die Sendungsverfolgung innerhalb einer Shopify-Bestellung oder im easyDHL-Portal erscheint die Meldung:
„Momentan liegen uns keine Daten zu dieser Sendung vor. Bitte versuchen Sie es zu einem späteren Zeitpunkt wieder.“
oder eine Fehler-URL wie:
https://dein-shop-domain.de/apps/tracking/error

Die Sendungen sind im DHL-Geschäftskundenportal korrekt hinterlegt, aber der Tracking-Link aus easyDHL funktioniert nicht.


Ursache

Das Problem tritt auf, wenn der Shopify App-Proxy nicht über die Hauptdomain des Shops erreichbar ist. Shopify leitet alle App-Proxy-Anfragen (z. B. /apps/tracking) ausschließlich über die im Shopify-Backend hinterlegte primäre Domain weiter.


In einigen Fällen führte GeoTagging zu einer entsprechenden Weiterleitungen zwischen den Domains was zu diesem Fehler führt.

Wenn euer Shop z. B. über dein-shop-domain.de aufgerufen wird, der App-Proxy aber auf dein-shop-domain.com registriert ist, werden die Parameter nicht an easyDHL weitergeleitet. Dadurch erscheint die Fehlerseite bzw. die Meldung „keine Daten vorhanden“.


Lösung

Da der App-Proxy von Shopify nicht manuell geändert werden kann, verwendet easyDHL in solchen Fällen einen Fallback-Link für neue Sendungen:

https://easydhl.247apps.de/app-proxy/show?shop=<shop-name>.myshopify.com&number=<sendungsnummer>


Diese Fallback-URL sorgt dafür, dass die Sendungsverfolgung wieder korrekt funktioniert.

Wichtig: Bereits bestehende (ältere) Tracking-Links bleiben unverändert und können weiterhin fehlerhaft sein, da sie über den ursprünglichen Proxy laufen.


Option in der App setzen!

In easyDHL gibt es eine Einstellung, um den Fallback aktiv zu erzwingen:

  1. easyDHL → Einstellungen → Trackingportal
  2. „App-Proxy deaktivieren“ aktivieren

Nach Aktivierung nutzt EasyDHL automatisch statt der Shop-Domain die folgende Domain/Route für neue Tracking-Links:

https://easydhl.247apps.de/app-proxy/show?shop=<shop-name>.myshopify.com&number=<sendungsnummer>

Damit wird der Shopify-Proxy vollständig umgangen und die Tracking-Links funktionieren unabhängig von der gewählten Shop-Domain zuverlässig.



War dieser Artikel hilfreich?

Das ist großartig!

Vielen Dank für das Feedback

Leider konnten wir nicht helfen

Vielen Dank für das Feedback

Wie können wir diesen Artikel verbessern?

Wählen Sie wenigstens einen der Gründe aus
CAPTCHA-Verifikation ist erforderlich.

Feedback gesendet

Wir wissen Ihre Bemühungen zu schätzen und werden versuchen, den Artikel zu korrigieren